use strict;
my $str = '1 (555)555-5555';
my $regex = qr/^([\d\s]*)\((\d{3})\)/p;
my $subst = '$1$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";