// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)'[^']*'(*SKIP)(*F)|[^'\s]*(\s{2,})[^'\s]*").unwrap();
let string = "update tabela set
nome='alberto da silva',
telefone='1234'
)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}