using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^http(s)?:\/\/[\\da-zA-Z\\-]+[.]+[\\da-zA-Z\\-]+[.]+[\\da-zA-Z\\-]+([.]+[\\da-zA-Z\\-]{1,3}|)$";
string input = @"https://www.googl.com";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}