import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^http(s)?:\\/\\/[\\\\da-zA-Z\\\\-]+[.]+[\\\\da-zA-Z\\\\-]+[.]+[\\\\da-zA-Z\\\\-]+([.]+[\\\\da-zA-Z\\\\-]{1,3}|)$";
final String string = "https://www.googl.com";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}