re = /^http(s)?:\/\/[\\da-zA-Z\\-]+[.]+[\\da-zA-Z\\-]+[.]+[\\da-zA-Z\\-]+([.]+[\\da-zA-Z\\-]{1,3}|)$/m
str = 'https://www.googl.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end