$re = '/^http(s)?:\/\/[\\\\da-zA-Z\\\\-]+[.]+[\\\\da-zA-Z\\\\-]+[.]+[\\\\da-zA-Z\\\\-]+([.]+[\\\\da-zA-Z\\\\-]{1,3}|)$/m';
$str = 'https://www.googl.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);