using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<!-- OPTIONAL -->(.*?)<!-- OPTIONAL END -->";
string input = @"<p>something</p>
<!-- OPTIONAL -->
<p class=""sdf""> some text</p>
<p> some other text</p>
<!-- OPTIONAL END -->
<p>The end</p>
<p>something</p>
<!-- OPTIONAL -->
<p class=""sdf""> some text</p>
<p> some other text</p>
<!-- OPTIONAL END -->
<p>The end</p>";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}