import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<!-- OPTIONAL -->(.*?)<!-- OPTIONAL END -->";
final String string = "<p>something</p>\n\n"
+ "<!-- OPTIONAL -->\n\n"
+ "<p class=\"sdf\"> some text</p>\n"
+ "<p> some other text</p>\n\n"
+ "<!-- OPTIONAL END -->\n\n"
+ "<p>The end</p>\n\n"
+ "<p>something</p>\n\n"
+ "<!-- OPTIONAL -->\n\n"
+ "<p class=\"sdf\"> some text</p>\n"
+ "<p> some other text</p>\n\n"
+ "<!-- OPTIONAL END -->\n\n"
+ "<p>The end</p>";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}