import re
regex = re.compile(r"<!-- OPTIONAL -->(.*?)<!-- OPTIONAL END -->", flags=re.DOTALL)
test_str = ("<p>something</p>\n\n"
"<!-- OPTIONAL -->\n\n"
"<p class=\"sdf\"> some text</p>\n"
"<p> some other text</p>\n\n"
"<!-- OPTIONAL END -->\n\n"
"<p>The end</p>\n\n"
"<p>something</p>\n\n"
"<!-- OPTIONAL -->\n\n"
"<p class=\"sdf\"> some text</p>\n"
"<p> some other text</p>\n\n"
"<!-- OPTIONAL END -->\n\n"
"<p>The end</p>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")