#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "([a-b-d-p-r-z-A-B-D-P-R-Z]{2}-[0-9]{2}-[0-9]{2})|([0-9]{2}-[0-9]{2}-[a-b-d-p-r-z-A-B-D-P-R-Z]{2})|([0-9]{2}-[a-b-d-p-r-z-A-B-D-P-R-Z]{2}-[0-9]{2})|([a-b-d-p-r-z-A-B-D-P-R-Z]{2}-[a-b-d-p-r-z-A-B-D-P-R-Z]{2}-[0-9]{2})|([a-b-d-p-r-z-A-B-D-P-R-Z]{2}-[0-9]{2}-[a-b-d-p-r-z-A-B-D-P-R-Z]{2})|([0-9]{2}-[a-b-d-p-r-z-A-B-D-P-R-Z]{2}-[a-b-d-p-r-z-A-B-D-P-R-Z]{2})|([0-9]{2}-[a-b-d-p-r-z-A-B-D-P-R-Z]{3}-[0-9]{1})|([0-9]{1}-[a-b-d-p-r-z-A-B-D-P-R-Z]{3}-[0-9]{2})|([a-b-d-p-r-z-A-B-D-P-R-Z]{2}-[0-9]{3}-[a-b-d-p-r-z-A-B-D-P-R-Z]{1})|([a-b-d-p-r-z-A-B-D-P-R-Z]{1}-[0-9]{3}-[a-b-d-p-r-z-A-B-D-P-R-Z]{2})|([a-b-d-p-r-z-A-B-D-P-R-Z]{3}-[0-9]{2}-[a-b-d-p-r-z-A-B-D-P-R-Z]{1})($|\ |\.|\,|\;|\r|\n|\r\n|\t) " & @CRLF & _
""
Local $sString = "ab-23-23" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")