const regex = /([a-b-d-p-r-z-A-B-D-P-R-Z]{2}-[0-9]{2}-[0-9]{2})|([0-9]{2}-[0-9]{2}-[a-b-d-p-r-z-A-B-D-P-R-Z]{2})|([0-9]{2}-[a-b-d-p-r-z-A-B-D-P-R-Z]{2}-[0-9]{2})|([a-b-d-p-r-z-A-B-D-P-R-Z]{2}-[a-b-d-p-r-z-A-B-D-P-R-Z]{2}-[0-9]{2})|([a-b-d-p-r-z-A-B-D-P-R-Z]{2}-[0-9]{2}-[a-b-d-p-r-z-A-B-D-P-R-Z]{2})|([0-9]{2}-[a-b-d-p-r-z-A-B-D-P-R-Z]{2}-[a-b-d-p-r-z-A-B-D-P-R-Z]{2})|([0-9]{2}-[a-b-d-p-r-z-A-B-D-P-R-Z]{3}-[0-9]{1})|([0-9]{1}-[a-b-d-p-r-z-A-B-D-P-R-Z]{3}-[0-9]{2})|([a-b-d-p-r-z-A-B-D-P-R-Z]{2}-[0-9]{3}-[a-b-d-p-r-z-A-B-D-P-R-Z]{1})|([a-b-d-p-r-z-A-B-D-P-R-Z]{1}-[0-9]{3}-[a-b-d-p-r-z-A-B-D-P-R-Z]{2})|([a-b-d-p-r-z-A-B-D-P-R-Z]{3}-[0-9]{2}-[a-b-d-p-r-z-A-B-D-P-R-Z]{1})($|\ |\.|\,|\;|\r|\n|\r\n|\t)
/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([a-b-d-p-r-z-A-B-D-P-R-Z]{2}-[0-9]{2}-[0-9]{2})|([0-9]{2}-[0-9]{2}-[a-b-d-p-r-z-A-B-D-P-R-Z]{2})|([0-9]{2}-[a-b-d-p-r-z-A-B-D-P-R-Z]{2}-[0-9]{2})|([a-b-d-p-r-z-A-B-D-P-R-Z]{2}-[a-b-d-p-r-z-A-B-D-P-R-Z]{2}-[0-9]{2})|([a-b-d-p-r-z-A-B-D-P-R-Z]{2}-[0-9]{2}-[a-b-d-p-r-z-A-B-D-P-R-Z]{2})|([0-9]{2}-[a-b-d-p-r-z-A-B-D-P-R-Z]{2}-[a-b-d-p-r-z-A-B-D-P-R-Z]{2})|([0-9]{2}-[a-b-d-p-r-z-A-B-D-P-R-Z]{3}-[0-9]{1})|([0-9]{1}-[a-b-d-p-r-z-A-B-D-P-R-Z]{3}-[0-9]{2})|([a-b-d-p-r-z-A-B-D-P-R-Z]{2}-[0-9]{3}-[a-b-d-p-r-z-A-B-D-P-R-Z]{1})|([a-b-d-p-r-z-A-B-D-P-R-Z]{1}-[0-9]{3}-[a-b-d-p-r-z-A-B-D-P-R-Z]{2})|([a-b-d-p-r-z-A-B-D-P-R-Z]{3}-[0-9]{2}-[a-b-d-p-r-z-A-B-D-P-R-Z]{1})($|\\ |\\.|\\,|\\;|\\r|\\n|\\r\\n|\\t)
', 'g')
const str = `ab-23-23
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}