# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = (r"([a-b-d-p-r-z-A-B-D-P-R-Z]{2}-[0-9]{2}-[0-9]{2})|([0-9]{2}-[0-9]{2}-[a-b-d-p-r-z-A-B-D-P-R-Z]{2})|([0-9]{2}-[a-b-d-p-r-z-A-B-D-P-R-Z]{2}-[0-9]{2})|([a-b-d-p-r-z-A-B-D-P-R-Z]{2}-[a-b-d-p-r-z-A-B-D-P-R-Z]{2}-[0-9]{2})|([a-b-d-p-r-z-A-B-D-P-R-Z]{2}-[0-9]{2}-[a-b-d-p-r-z-A-B-D-P-R-Z]{2})|([0-9]{2}-[a-b-d-p-r-z-A-B-D-P-R-Z]{2}-[a-b-d-p-r-z-A-B-D-P-R-Z]{2})|([0-9]{2}-[a-b-d-p-r-z-A-B-D-P-R-Z]{3}-[0-9]{1})|([0-9]{1}-[a-b-d-p-r-z-A-B-D-P-R-Z]{3}-[0-9]{2})|([a-b-d-p-r-z-A-B-D-P-R-Z]{2}-[0-9]{3}-[a-b-d-p-r-z-A-B-D-P-R-Z]{1})|([a-b-d-p-r-z-A-B-D-P-R-Z]{1}-[0-9]{3}-[a-b-d-p-r-z-A-B-D-P-R-Z]{2})|([a-b-d-p-r-z-A-B-D-P-R-Z]{3}-[0-9]{2}-[a-b-d-p-r-z-A-B-D-P-R-Z]{1})($|\ |\.|\,|\;|\r|\n|\r\n|\t) \n")
test_str = ("ab-23-23\n")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.