import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "http://139.155.123.45:8001/app/sys/console/index.tfp\n"
+ "https:scontentxxfbcdnnethads-ak-prn21487645_6012475414660_1439393861_npng\n";
final String string = "\n"
+ "us1.getyooz.com\n\n"
+ "const audioContext = new (window.AudioContext || window.webkitAudioContext)();\n\n\n"
+ "const oscillator = audioContext.createOscillator();\n\n\n"
+ "oscillator.frequency.setValueAtTime(440, audioContext.currentTime); // A4 note\n\n\n"
+ "oscillator.connect(audioContext.destination);\n\n\n"
+ "oscillator.start();\n\n\n"
+ "oscillator.stop(audioContext.currentTime + 2);\n";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CASE | Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}