const regex = /http://139.155.123.45:8001/app/sys/console/index.tfp
https:scontentxxfbcdnnethads-ak-prn21487645_6012475414660_1439393861_npng
/uimg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('http:\/\/139.155.123.45:8001\/app\/sys\/console\/index.tfp
https:scontentxxfbcdnnethads-ak-prn21487645_6012475414660_1439393861_npng
', 'uimg')
const str = `
us1.getyooz.com
const audioContext = new (window.AudioContext || window.webkitAudioContext)();
const oscillator = audioContext.createOscillator();
oscillator.frequency.setValueAtTime(440, audioContext.currentTime); // A4 note
oscillator.connect(audioContext.destination);
oscillator.start();
oscillator.stop(audioContext.currentTime + 2);
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}