package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)<span[^>]+class="[^"]*\btxt_arial_8pt_black\b[^"]*"[^>]*>(.*)</span>`)
var str = `<span class="txt_arial_8pt_black">Antes <span>Durante</span> Depois</span>
<span class="txt_arial_8pt_black">outro</span><br>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}