re = /<span[^>]+class="[^"]*\btxt_arial_8pt_black\b[^"]*"[^>]*>(.*)<\/span>/
str = '<span class="txt_arial_8pt_black">Antes <span>Durante</span> Depois</span>
<span class="txt_arial_8pt_black">outro</span><br>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end