import re
regex = re.compile(r"^(\/[^\/]*\/[^\/]*\/[^\/]*\/[^\/]*\/)(.*)$", flags=re.MULTILINE)
test_str = "/testNAS/questions/ask/test/example/picture.png"
subst = "$1;$2"
result = regex.sub(subst, test_str)
if result:
print(result)