const regex = /\h*(?<!\=|\!|^)([!=<>+-]+)(?!\=|\!|$)\h*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\h*(?<!\\=|\\!|^)([!=<>+-]+)(?!\\=|\\!|$)\\h*', 'gm')
const str = `а= 3
а =3
а=3
а= 3
а =3
а=3
а= 3
а =3
а=3
a+b
a+ b
a +b
a + b
c>d
c >d
c> d
a<b
a <b
a < b
a< b
a==b
a<>b
a !=b
========================`;
const subst = ` \1 `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);