$re = '/\h*(?<!\=|\!|^)([!=<>+-]+)(?!\=|\!|$)\h*/m';
$str = 'а= 3
а =3
а=3
а= 3
а =3
а=3
а= 3
а =3
а=3
a+b
a+ b
a +b
a + b
c>d
c >d
c> d
a<b
a <b
a < b
a< b
a==b
a<>b
a !=b
========================';
$subst = " \1 ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;