use strict;
my $str = 'а= 3
а =3
а=3
а= 3
а =3
а=3
а= 3
а =3
а=3
a+b
a+ b
a +b
a + b
c>d
c >d
c> d
a<b
a <b
a < b
a< b
a==b
a<>b
a !=b
========================';
my $regex = qr/\h*(?<!\=|\!|^)([!=<>+-]+)(?!\=|\!|$)\h*/mp;
my $subst = ' \\1 ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";