using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Name[:.] \K[^\r\n]*";
string input = @"Name: John Smith
Full Name: John Smith
F. Name: John Smith
First/Last Name: John Smith
Name. John Smith";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}