$re = '/Name[:.] \K[^\r\n]*/';
$str = 'Name: John Smith
Full Name: John Smith
F. Name: John Smith
First/Last Name: John Smith
Name. John Smith';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);