const regex = /Name[:.] \K[^\r\n]*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Name[:.] \\K[^\\r\\n]*', 'g')
const str = `Name: John Smith
Full Name: John Smith
F. Name: John Smith
First/Last Name: John Smith
Name. John Smith`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}