re = /Name[:.] \K[^\r\n]*/
str = 'Name: John Smith
Full Name: John Smith
F. Name: John Smith
First/Last Name: John Smith
Name. John Smith'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end