using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^ssh:\/\/git@(?<HOSTNAME>github.+?)\/(?<REPOSITORY_PATH>.+?)(\.git)?$";
string input = @"ssh://git@github.com/demotechinc/demotech-gitops";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}