$re = '/^ssh:\/\/git@(?<HOSTNAME>github.+?)\/(?<REPOSITORY_PATH>.+?)(\.git)?$/m';
$str = 'ssh://git@github.com/demotechinc/demotech-gitops';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);