package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^ssh:\/\/git@(?<HOSTNAME>github.+?)\/(?<REPOSITORY_PATH>.+?)(\.git)?$`)
var str = `ssh://git@github.com/demotechinc/demotech-gitops`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}