re = /^ssh:\/\/git@(?<HOSTNAME>github.+?)\/(?<REPOSITORY_PATH>.+?)(\.git)?$/m
str = 'ssh://git@github.com/demotechinc/demotech-gitops'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end