using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=[A-Z][a-z])";
string substitution = @"-";
string input = @"B2BNewQuoteProcess";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}