$re = '/(?=[A-Z][a-z])/';
$str = 'B2BNewQuoteProcess';
$subst = "-";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;