use strict;
my $str = 'B2BNewQuoteProcess';
my $regex = qr/(?=[A-Z][a-z])/p;
my $subst = '-';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";