import Foundation
let pattern = #"(?=[A-Z][a-z])"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"B2BNewQuoteProcess"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"-"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)