#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?msU)<emphasis>(.*) Code<\/emphasis>\s*<\/para>\s*<program ?(language="(.*)")?>\s*(.*)<\/program>"
Local $sString = " <section id="foo">" & @CRLF & _
" <title>Code about Bears</title>" & @CRLF & _
"" & @CRLF & _
" <para>Words</para>" & @CRLF & _
" " & @CRLF & _
" <para><emphasis>Python Code</emphasis></para>" & @CRLF & _
" <program language="py">import bears</program>" & @CRLF & _
"" & @CRLF & _
" <para><emphasis>JavaScript Code</emphasis></para>" & @CRLF & _
" <program language="js">var bear = require('bears');</program>" & @CRLF & _
" " & @CRLF & _
" <section id="bar">" & @CRLF & _
" <title>Code about Bear Cubs</title>" & @CRLF & _
"" & @CRLF & _
" <para>Words</para>" & @CRLF & _
" " & @CRLF & _
" <para><emphasis>Python Code</emphasis></para>" & @CRLF & _
" <program language="py">import cubs</program>" & @CRLF & _
"" & @CRLF & _
" <para><emphasis>JavaScript Code</emphasis></para>" & @CRLF & _
" <program language="js">var cub = require('cubs');</program>" & @CRLF & _
" </section>" & @CRLF & _
" </section>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")