import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<emphasis>(.*) Code<\\/emphasis>\\s*<\\/para>\\s*<program ?(language=\"(.*)\")?>\\s*(.*)<\\/program>";
final String string = " <section id=\"foo\">\n"
+ " <title>Code about Bears</title>\n\n"
+ " <para>Words</para>\n"
+ " \n"
+ " <para><emphasis>Python Code</emphasis></para>\n"
+ " <program language=\"py\">import bears</program>\n\n"
+ " <para><emphasis>JavaScript Code</emphasis></para>\n"
+ " <program language=\"js\">var bear = require('bears');</program>\n"
+ " \n"
+ " <section id=\"bar\">\n"
+ " <title>Code about Bear Cubs</title>\n\n"
+ " <para>Words</para>\n"
+ " \n"
+ " <para><emphasis>Python Code</emphasis></para>\n"
+ " <program language=\"py\">import cubs</program>\n\n"
+ " <para><emphasis>JavaScript Code</emphasis></para>\n"
+ " <program language=\"js\">var cub = require('cubs');</program>\n"
+ " </section>\n"
+ " </section>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL | Pattern.UNICODE_CHARACTER_CLASS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}