using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<emphasis>(.*) Code<\/emphasis>\s*<\/para>\s*<program ?(language=""(.*)"")?>\s*(.*)<\/program>";
string input = @" <section id=""foo"">
<title>Code about Bears</title>
<para>Words</para>
<para><emphasis>Python Code</emphasis></para>
<program language=""py"">import bears</program>
<para><emphasis>JavaScript Code</emphasis></para>
<program language=""js"">var bear = require('bears');</program>
<section id=""bar"">
<title>Code about Bear Cubs</title>
<para>Words</para>
<para><emphasis>Python Code</emphasis></para>
<program language=""py"">import cubs</program>
<para><emphasis>JavaScript Code</emphasis></para>
<program language=""js"">var cub = require('cubs');</program>
</section>
</section>";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}