package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?msU)<emphasis>(.*) Code<\/emphasis>\s*<\/para>\s*<program ?(language="(.*)")?>\s*(.*)<\/program>`)
var str = ` <section id="foo">
<title>Code about Bears</title>
<para>Words</para>
<para><emphasis>Python Code</emphasis></para>
<program language="py">import bears</program>
<para><emphasis>JavaScript Code</emphasis></para>
<program language="js">var bear = require('bears');</program>
<section id="bar">
<title>Code about Bear Cubs</title>
<para>Words</para>
<para><emphasis>Python Code</emphasis></para>
<program language="py">import cubs</program>
<para><emphasis>JavaScript Code</emphasis></para>
<program language="js">var cub = require('cubs');</program>
</section>
</section>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}