import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\w+: (.*)$\n"
+ "\\w+: (.*)$\n"
+ "\\w+: (.*)$";
final String string = "Colombo: tentio.milenium:02\n"
+ "TestL: u29kae.ee\n"
+ "Restric: free28os\n";
final String subst = "$2:$3@$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}