// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\w+: (.*)$
\w+: (.*)$
\w+: (.*)$").unwrap();
let string = "Colombo: tentio.milenium:02
TestL: u29kae.ee
Restric: free28os
";
let substitution = "$2:$3@$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}