const regex = /\w+: (.*)$
\w+: (.*)$
\w+: (.*)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\w+: (.*)$
\\w+: (.*)$
\\w+: (.*)$', 'gm')
const str = `Colombo: tentio.milenium:02
TestL: u29kae.ee
Restric: free28os
`;
const subst = `$2:$3@$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);