import Foundation
let pattern = #"""
\w+: (.*)$
\w+: (.*)$
\w+: (.*)$
"""#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Colombo: tentio.milenium:02
TestL: u29kae.ee
Restric: free28os
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$2:$3@$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)