package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\w+: ([^\s]*)$\n\w+: ((?1))\n\w+: ((?2))$`)
var str = `Colombo: tentio.milenium:02
TestL: u29kae.ee
Restric: free28os
`
var substitution = "$2:$3@$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}