re = /\w+: ([^\s]*)$\n\w+: ((?1))\n\w+: ((?2))$/m
str = 'Colombo: tentio.milenium:02
TestL: u29kae.ee
Restric: free28os
'
subst = '$2:$3@$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result