# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\w+: ([^\s]*)$\n\w+: ((?1))\n\w+: ((?2))$"
test_str = ("Colombo: tentio.milenium:02\n"
"TestL: u29kae.ee\n"
"Restric: free28os\n")
subst = "$2:$3@$1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.