#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)jdbc:(.*?):[\/@]+(.*?):([0-9]+);(?:databaseName)=([a-z_]+)"
Local $sString = "jdbc:sqlserver://vmsqlentpag03:1433;databaseName=SEPM_PRD;integratedSecurity=true;encrypt=true;trustServerCertificate=true;domain=HERSHEY"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")