const regex = /jdbc:(.*?):[\/@]+(.*?):([0-9]+);(?:databaseName)=([a-z_]+)/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('jdbc:(.*?):[\\\/@]+(.*?):([0-9]+);(?:databaseName)=([a-z_]+)', 'gmi')
const str = `jdbc:sqlserver://vmsqlentpag03:1433;databaseName=SEPM_PRD;integratedSecurity=true;encrypt=true;trustServerCertificate=true;domain=HERSHEY`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}