import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "jdbc:(.*?):[\\/@]+(.*?):([0-9]+);(?:databaseName)=([a-z_]+)";
final String string = "jdbc:sqlserver://vmsqlentpag03:1433;databaseName=SEPM_PRD;integratedSecurity=true;encrypt=true;trustServerCertificate=true;domain=HERSHEY";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}