package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)jdbc:(.*?):[\/@]+(.*?):([0-9]+);(?:databaseName)=([a-z_]+)`)
var str = `jdbc:sqlserver://vmsqlentpag03:1433;databaseName=SEPM_PRD;integratedSecurity=true;encrypt=true;trustServerCertificate=true;domain=HERSHEY`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}