#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\/\*\s+(\/\/.+)[\s\S]+\*\/"
Local $sString = "/*" & @CRLF & _
" // random unmanaged annotation" & @CRLF & _
" foo = var;" & @CRLF & _
" doSomething();" & @CRLF & _
" multilineFunction(a," & @CRLF & _
" b);" & @CRLF & _
"*/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")