package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\/\*\s+(\/\/.+)[\s\S]+\*\/`)
var str = `/*
// random unmanaged annotation
foo = var;
doSomething();
multilineFunction(a,
b);
*/`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}