re = /\/\*\s+(\/\/.+)[\s\S]+\*\//m
str = '/*
// random unmanaged annotation
foo = var;
doSomething();
multilineFunction(a,
b);
*/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end